Discussion:
RB-TFT 3.5 auf Raspi mount problem?
(zu alt für eine Antwort)
Kay Martinen
2017-12-18 07:37:07 UTC
Permalink
Hallo

Ich hab ein Joy-IT RB-TFT 3.5" Display zum Aufstecken auf den GPIO für
meinen Raspi hier. Das soll angeblich auf jeden Raspi passen. Ich habe
es mit einem alten Raspi 1b versucht, lt. der Anleitung das
Raspian-image von deren Seite geladen, mit win32diskimager auf eine 8 GB
SD gespeichert und versucht zu starten. Leider leuchtete erst nur die
Rote LED. Beim nachsehen stelle ich fest das die SD leer blieb. Also
noch mal geschrieben, Verify gemacht und es ist okay.

Jetzt leuchtete zu der Roten auch noch die Gelbe LED kurz. Die
Hintergrundbeleuchtung des Displays ging wie vorher auch an, aber weiter
passierte nichts.

Jetzt hab ich es mal an einen Fernseher per HDMI angeschlossen. Und da
sehe ich das der Kernel offenbar startet, dann aber mit Kernel-panic
stecken bleibt. Die genaue meldung weiß ich nicht mehr (vergaß ein Photo
zu machen) doch es ging um das mounten und einen "wrong fs-type" und ich
meine noch ext4 gelesen zu haben.

Kennt das Problem jemand (der auch dieses Display hat) oder hat evtl.
jemand eine Lösungsidee?

Mir scheint es als ob da entweder eine initrd oder die eigentliche
raspian-partition irgendwie nicht erreicht werden kann.

Auf einem Ubuntu sehe ich auf der SD eine Partition "Boot" und eine
weitere. Boot kann ich lesen, die andere produziert beim mount-versuch
(mit KDE) auch einen Fehler "wrong fs-type"

Das ist; soweit ich weiß; kein Noobs-Installer der beim ersten Start ein
Auswahlmenü präsentiert (per HDMI, was ich hier beim 1. Start nicht
hätte sehen können). Und das ich einen kernel-panic sehe spricht IMHO
auch dafür das dort direkt ein kernel starten soll.

Bin mom. etwas ratlos ob ein weiteres mal SD Schreiben hilft oder ob
dies Image einfach broken-per-design ist. Runter laden musste man das
von einem Owncloud von Joy-IT. Bisschen merkwürdig oder?

Kay
Marcel Mueller
2017-12-21 16:27:44 UTC
Permalink
Post by Kay Martinen
Jetzt leuchtete zu der Roten auch noch die Gelbe LED kurz. Die
Hintergrundbeleuchtung des Displays ging wie vorher auch an, aber weiter
passierte nichts.
Die SD bootet nicht.
Post by Kay Martinen
Jetzt hab ich es mal an einen Fernseher per HDMI angeschlossen. Und da
sehe ich das der Kernel offenbar startet, dann aber mit Kernel-panic
stecken bleibt.
Genau deshalb.
Post by Kay Martinen
Die genaue meldung weiß ich nicht mehr (vergaß ein Photo
zu machen) doch es ging um das mounten und einen "wrong fs-type" und ich
meine noch ext4 gelesen zu haben.
Der Inhalt der SD-Karte taugt nichts.
Post by Kay Martinen
Kennt das Problem jemand (der auch dieses Display hat) oder hat evtl.
jemand eine Lösungsidee?
Die erste spannende Frage ist, ob dieses Display vom Standard-Raspbian
Kernel OOTB unterstützt wird.
Wenn ja: aktuelles Standard-Raspbian-Image nehmen, und fertig.
Wenn nein, bedeutet das faktisch dass Du keine Updates mehr bekommst,
weder Firmware noch Kernel. Der Hersteller wird jedenfalls nicht alle
paar Wochen den Treiber für das jeweils neueste Raspbian portieren.
Post by Kay Martinen
Mir scheint es als ob da entweder eine initrd oder die eigentliche
raspian-partition irgendwie nicht erreicht werden kann.
Möglich. Man kann über die Eigenschaften des kaputten Image nur raten.
Post by Kay Martinen
Auf einem Ubuntu sehe ich auf der SD eine Partition "Boot" und eine
weitere. Boot kann ich lesen, die andere produziert beim mount-versuch
(mit KDE) auch einen Fehler "wrong fs-type"
Der Inhalt deiner SD-Karte ist immer noch kaputt. Ubuntu kann /jede/
Partition lesen, die auch Raspbian lesen kann. Ist beides im
wesentlichen der Linux-Kernel.
Post by Kay Martinen
Das ist; soweit ich weiß; kein Noobs-Installer der beim ersten Start ein
Auswahlmenü präsentiert (per HDMI, was ich hier beim 1. Start nicht
hätte sehen können). Und das ich einen kernel-panic sehe spricht IMHO
auch dafür das dort direkt ein kernel starten soll.
Ack.
Post by Kay Martinen
Bin mom. etwas ratlos ob ein weiteres mal SD Schreiben hilft oder ob
dies Image einfach broken-per-design ist. Runter laden musste man das
von einem Owncloud von Joy-IT. Bisschen merkwürdig oder?
Ja, definitiv.

Gibt es Image-Prüfsummen zum runterladen? Wenn ja, solltest Du die
dringend mal verifizieren.
Aber ehrlich gesagt, wird das mittelfristig sowieso nichts. Ich habe
bisher ausschließlich schlechte Erfahrung mit Images von
Hardwareherstellern gemacht. Damit funktioniert, wenn überhaupt, nur die
eine Hardware. Ansonsten sind sie üblicherweise einfach nur veraltet,
schlecht und nicht updatefähig. Sobald man ein Firmware-Update einspielt
- braucht man für einige Features bzw. neuere Kernel - war es das.
Entweder läuft dann die Hardware nicht mehr oder gar nichts mehr.

Ich würde zusehen, das Display mit einem Standard-RPi-Image zum laufen
zu bringen. Mutmaßlich brauchst Du nur das Device-Tree-Overlay in den
boot-Ordner reinfrickeln - siehe Expert-Section. Wie lange dieses zu
neueren Kerneln kompatibel bleibt, weißt Du an dem Tag, wo der
Bildschirm dunkel wird. ;-)


Marcel

Loading...