Discussion:
Netzteildefekt ursaechlich fuer Anlaufprobleme nach Suspend-to-RAM?
(zu alt für eine Antwort)
Marc Haber
2018-06-16 10:59:37 UTC
Permalink
Raw Message
Hallo,

mein (unter Linux laufender) Desktop-Rechner daheim wird von mir nach
Ende seiner Nutzung ins Suspend-to-RAM geschickt und am nächsten Tag
entweder per Wake-on-LAN oder lokal durch Betätigung einer Taste auf
der Tastatur wieder aufgeweckt.

Seit einigen Wochen wacht er nicht mehr sauber auf, oder nur noch
jedes fünfte Mal oder so. Das Symptom ist, dass die Lüfter anlaufen,
die LEDs kurz blinken, die Power-LED vom Standby-Blinken in das
normale Dauerleuchten übergeht, die Platte anläuft, das DVD-Laufwerk
seinen Kopf einmal hin- und her bewegt, der Ethernet-Link hoch kommt
und dass ansonsten nichts geht: Bildschirm bleibt dunkel, keine
Reaktion im Netz (es geht nichtmal ein DCHP-Request raus), keine
Reaktion mit der NumLock-LED, wenn man die entsprechende Taste drückt.

Außergewöhnlich und nicht zu einem "normalen" Absturz passend ist,
dass auch der Reset-Knopf am Gehäuse ignoriert wird. Ich dachte immer,
dass der Reset-Knopf ziemlich direkt die Power-Good-Leitung des
Netzteils kappt, und auf diese Weise sehr "nahe an der Hardware" für
einen Reset sorgt. Lange auf den Powerknopf drücken hilft aber, die
Kiste läuft dann wieder an, aber halt "neu".

Wenn sie einmal läuft, dann läuft sie. Und zwar auch unter Last.

Ich kann mir nun vorstellen, dass das Aufwachen aus dem Suspend für
das Netzteil ein ziemlicher Streßmoment ist, vor allen Dingen weil die
eigentlich nicht benötigte Platte erst einmal mit anläuft.

Die Kiste ist nicht mehr die allerfrischste, von 2011, aber "noch
gut".

Kann das ein sich anbahnender Defekt im Netzteil sein? Das wäre ja
halbwegs einfach zu tauschen, neues Netzteil ~ 35 Euro plus eine halbe
Stunde basteln. Was würdet Ihr hier machen?

Grüße
Marc
--
-------------------------------------- !! No courtesy copies, please !! -----
Marc Haber | " Questions are the | Mailadresse im Header
Mannheim, Germany | Beginning of Wisdom " |
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834
Bastian Lutz
2018-06-16 11:20:01 UTC
Permalink
Raw Message
Hallo Marc!
Post by Marc Haber
mein (unter Linux laufender) Desktop-Rechner daheim wird von mir nach
Ende seiner Nutzung ins Suspend-to-RAM geschickt und am nächsten Tag
entweder per Wake-on-LAN oder lokal durch Betätigung einer Taste auf
der Tastatur wieder aufgeweckt.
Seit einigen Wochen wacht er nicht mehr sauber auf, oder nur noch
jedes fünfte Mal oder so.
Kannst du evtl. den Zustand deines Linux von vor >"einigen Wochen"
wiederherstellen? Wenn das out-of-the-box ging evtl. die entspr. Version
als Live-Linux booten? Theoretisch
- kann der neuere Kernel schuld sein, der ja regelm. upgedatet werden
sollte (auch wenn sich die Kernel theoretisch nur durch Bugfixes
unterscheiden sollten, also Versionsnr. nur ganz hinten erhoeht)
- bzw. du hast was geaendert wodurch ein beschissener Treiber aktiv
wurde (OpenSource-Treiber vs. proprietaerer Treiber oder schlicht was an
der Hardware geaendert inkl. neues USB-Geraet angesteckt?)
- bzw. das Zusammenspiel mit dem BIOS/UEFI (wobei ein Update von
BIOS/UEFI theoretisch auch helfen kann).

Eine generelle Empfehlung fuer den Anfang waere auch mal alle Hardware
zu entfernen, die du nicht ganz dringend brauchst (dringend ist z. B.
Tastatur und Monitor, evtl. auch Maus), inkl. Steckkarten, anderer
USB-Geraete & Co. Natuerl. auch dafuer sorgen, dass die entspr. Treiber
nicht aktiv sein, die eigentl. nicht benoetigt werden.

Netzteil-/Mainboard-Hardware-Probleme kann ich aber auch nicht 100%ig
ausschliessen, hatte sowas aber bei so einem Fehlerbild aber noch nie
als Uebeltaeter (auch weil ich S2R so gut wie nicht verwende).

Aber es kann halt auch irgendwann zieml. Richtung Linux-Problem gehen,
da waerst du hier eher in der falschen Gruppe.

Bastian Lutz
--
Wenn jemand irgendwas von Anonymitaet faselt, wenn er oder jemand
anderes (meist Newbies) darauf hingewiesen wurde, dass er einen Realname
verwenden sollte, hat er den Hinweis nicht richtig gelesen.
Patrick Rudin
2018-06-16 12:02:48 UTC
Permalink
Raw Message
Post by Marc Haber
Außergewöhnlich und nicht zu einem "normalen" Absturz passend ist,
dass auch der Reset-Knopf am Gehäuse ignoriert wird.
Da würd ich erstmal nachgucken, ob dessen Stecker auf dem Mainboard
richtig (und am richtigen Ort) gesteckt ist.
Post by Marc Haber
Wenn sie einmal läuft, dann läuft sie. Und zwar auch unter Last.
Was imho eher gegen Netzteilprobleme spricht.

Falls Du Testing oder gar Unstable fährst, wäre ein Test mit einer
älteren Live-CD vermutlich erste Wahl punkto Fehlerdiagnose.


Gruss

Patrick
Marc Haber
2018-06-16 15:22:37 UTC
Permalink
Raw Message
Post by Patrick Rudin
Post by Marc Haber
Außergewöhnlich und nicht zu einem "normalen" Absturz passend ist,
dass auch der Reset-Knopf am Gehäuse ignoriert wird.
Da würd ich erstmal nachgucken, ob dessen Stecker auf dem Mainboard
richtig (und am richtigen Ort) gesteckt ist.
Im Normalbetrieb und bei "normalen" Abstürzen funktioniert er.
Post by Patrick Rudin
Falls Du Testing oder gar Unstable fährst, wäre ein Test mit einer
älteren Live-CD vermutlich erste Wahl punkto Fehlerdiagnose.
Dankeschön, normalerweise bin ich derjenige, der die Tipps zur
Fehlersuche in Linux gibt. Darum geht es mir hier aber nicht.

Grüße
Marc
--
-------------------------------------- !! No courtesy copies, please !! -----
Marc Haber | " Questions are the | Mailadresse im Header
Mannheim, Germany | Beginning of Wisdom " |
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834
Michael Bäuerle
2018-06-16 22:44:42 UTC
Permalink
Raw Message
Post by Patrick Rudin
Post by Marc Haber
Außergewöhnlich und nicht zu einem "normalen" Absturz passend ist,
dass auch der Reset-Knopf am Gehäuse ignoriert wird.
Da würd ich erstmal nachgucken, ob dessen Stecker auf dem Mainboard
richtig (und am richtigen Ort) gesteckt ist.
Post by Marc Haber
Wenn sie einmal läuft, dann läuft sie. Und zwar auch unter Last.
Was imho eher gegen Netzteilprobleme spricht.
Würde ich nicht so sehen. Mir ist vor ein paar Tagen im Büro auch das
Netzteil in der Workstation gestorben, es hat beim einschalten rum-
gesponnen (klick, klack, klick, ...). Am Anfang lief es dann ein paar
Mal noch den Rest vom Tag, wenn ich es einmal laufen hatte. Nach wenigen
Tagen liess es sich dann aber gar nicht mehr einschalten.

Thorsten Albrecht
2018-06-16 14:29:52 UTC
Permalink
Raw Message
Post by Marc Haber
Seit einigen Wochen wacht er nicht mehr sauber auf, oder nur noch
jedes fünfte Mal oder so.
...
Wenn sie einmal läuft, dann läuft sie. Und zwar auch unter Last.
...
Kann das ein sich anbahnender Defekt im Netzteil sein? Das wäre ja
halbwegs einfach zu tauschen, neues Netzteil ~ 35 Euro plus eine halbe
Stunde basteln. Was würdet Ihr hier machen?
Ich hatte exakt das gleiche Problem mit einem komplett neuen Mainboard
(Asus Q170M-C). M. E. stürzte das Mainboard beim Aufwachen aus S3 auf
der niedrigsten Hardware-Ebene ab, d.h. das Betriebssystem konnte
nichts dafür. "Beweisen" konnte ich dieses, weil das Mainboard einen
Q170-Chipsatz besitzt, welcher via Intel AMT remote angesteuert werden
kann, und zwar in JEDEM Zustand des Rechners. Allerdings ging Intel
AMT in - abgestürzten - Zustand nicht. Ergo: Das Mainboard" selbst
war also abgestürzt.

Ein Netzteiltausch, den ich sowieso vor hatte (aufgrund längerer
Kabel), brachte in keinster Weise eine Besserung. Das hatte ich auch
nicht erwartet, da das Netzteil sowieso nur ein paar Wochen alt war
und von guter Qualität. Wäre auch sehr unwahrscheinlich, dass ein
neues BeQuiet PurePower 350W-NT Probleme mit dem Aufwachen aus S3 bei
einem auf einen niedrigen Verbrauch getrimmten Rechner hat.

Besserung brachte ein Austausch des Mainboards über den Händler.
Danach habe ich dieses Problem nie wieder erlebt. (Und davor übrigens
auch nicht.). Insofern mein Rat: Mainboard-Tausch. Tut weh, ich weiß.
Aber alles andere tut noch mehr weh.

Thorsten
Marc Haber
2018-06-16 15:23:29 UTC
Permalink
Raw Message
Post by Thorsten Albrecht
Besserung brachte ein Austausch des Mainboards über den Händler.
Danach habe ich dieses Problem nie wieder erlebt. (Und davor übrigens
auch nicht.). Insofern mein Rat: Mainboard-Tausch. Tut weh, ich weiß.
Aber alles andere tut noch mehr weh.
Dann ist der ganze Rechner fällig. Würde ich gerne vermeiden. Aktuell
weiß ich nichtmal, ob da vielleicht gar noch eine PCI-Karte drin
steckt.

Grüße
Marc
--
-------------------------------------- !! No courtesy copies, please !! -----
Marc Haber | " Questions are the | Mailadresse im Header
Mannheim, Germany | Beginning of Wisdom " |
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834
Loading...